Skip to content

← Public intelligence

RubyGems package

railties

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8RubyGemsPublished

    Use of Insufficiently Random Values in Railties Allows Remote Code Execution

    CVE-2019-5420 · GHSA-m42h-mh85-4qgc

    Affected
    • RubyGems railties >= 5.2.0, <= 5.2.2.0
    Fixed in
    5.2.2.1· Vendor fix available
    Issue
    Possible Remote Code Execution Exploit in Rails Development Mode Impact ------ With some knowledge of a target application it is possible for an attacker to guess the automatically generated development mode secret token. This secret token can be used in combination with other Rails internals to escalate to a remote code execution exploit. All users running an affected release should either upgrade or use one of the workarounds immediately. Releases -------- The 6.0.0.beta3 and 5.2.2.1 releases are available at the normal locations. Workarounds ----------- This issue can be mitigated by specifying a secret key in development mode. In "config/environments/development.rb" add this: Please note that only the 5.2.x, 5.1.x, 5.0.x, and 4.2.x series are supported at present. Users of earlier unsupported releases are advised to upgrade as soon as possible as we cannot guarantee the continued availability of security fixes for unsupported releases. Credits ------- Thanks to oooooooq

    Recommended action: Upgrade to 5.2.2.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →