Skip to content

← Actionable
Critical, CVSS 9.8

Use of Insufficiently Random Values in Railties Allows Remote Code Execution

CVE-2019-5420GHSA-m42h-mh85-4qgc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (railties 5.2.2.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems railties

    Affected
    >= 5.2.0, <= 5.2.2.0
    Fixed in
    5.2.2.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2019-5420: 89.33% estimated exploitation activity in the next 30 days; percentile 99.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Possible Remote Code Execution Exploit in Rails Development Mode Impact ------ With some knowledge of a target application it is possible for an attacker to guess the automatically generated development mode secret token. This secret token can be used in combination with other Rails internals to escalate to a remote code execution exploit. All users running an affected release should either upgrade or use one of the workarounds immediately. Releases -------- The 6.0.0.beta3 and 5.2.2.1 releases are available at the normal locations. Workarounds ----------- This issue can be mitigated by specifying a secret key in development mode. In "config/environments/development.rb" add this: Please note that only the 5.2.x, 5.1.x, 5.0.x, and 4.2.x series are supported at present. Users of earlier unsupported releases are advised to upgrade as soon as possible as we cannot guarantee the continued availability of security fixes for unsupported releases. Credits ------- Thanks to oooooooq

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-m42h-mh85-4qgc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-5420

Advisory: Use of Insufficiently Random Values in Railties Allows Remote Code Execution
IDs: CVE-2019-5420, GHSA-m42h-mh85-4qgc
Record: https://patchnext.com/advisories/cve-2019-5420 (revision 1, source checked 26 Oct 2026, 15:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: railties 5.2.2.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems railties: affected >= 5.2.0, <= 5.2.2.0; fixed in 5.2.2.1

## Suggested inspection (read-only)
- RubyGems railties: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on railties.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m42h-mh85-4qgc (GitHub-reviewed advisory GHSA-m42h-mh85-4qgc lists affected ranges: RubyGems railties >=5.2.0 <=5.2.2.0)

Commands are suggestions: review each one before running it.

Loading voting…