Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.
Open advisories
15 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.
A publisher on a publify application is able to perform a cross-site scripting attack on an administrator using the redirect functionality. Details A publisher on a publify application is able to perform a cross-site scripting attack on an administrator using the redirect functionality. The exploitation of this XSS vulnerability requires the administrator to click a malicious link. We can create a redirect to a javascript:alert() URL. Whilst the redirect itself doesn't work, on the administrative panel, an a tag is created with the payload as the URI. Upon clicking this link, the XSS is triggered. An attack could attempt to hide their payload by using HTML, or other encodings, as to not make it obvious to an administrator that this is a malicious link. PoC A publisher can create a new redirect as shown below. The payload used is javascript:alert(). An administrator will now see this redirect in their overview of the page. If they click the link on the right, it triggers the…
Recommended action: Upgrade to 10.0.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
Weak Password Requirements in GitHub repository publify/publify prior to 9.2.10.
Recommended action: Upgrade to 9.2.10 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
Integer Overflow or Wraparound in GitHub repository publify/publify prior to 9.2.10 due to an unlimited length user name field.
Recommended action: Upgrade to 9.2.10 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
Insecure Storage of Sensitive Information in GitHub repository publify/publify prior to 9.2.10.
Recommended action: Upgrade to 9.2.10 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
Improper Input Validation in GitHub repository publify/publify prior to 9.2.10.
Recommended action: Upgrade to 9.2.10 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
In Publify, versions v8.0 to v9.2.4 are vulnerable to stored XSS. A user with a “publisher” role is able to inject and execute arbitrary JavaScript code while creating a page/article.
Recommended action: Upgrade to 9.2.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
In publify, versions v8.0 to v9.2.4 are vulnerable to stored XSS as a result of an unrestricted file upload. This issue allows a user with “publisher” role to inject malicious JavaScript via the uploaded html file.
Recommended action: Upgrade to 9.2.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
A low-privileged user can modify and delete admin articles by changing the value of the article[id] parameter prior to 9.2.9.
Recommended action: Upgrade to 9.2.9 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
Unrestricted file upload allowed the attacker to manipulate the request and bypass the protection of HTML files using a text file. Stored XSS may be obtained.
Recommended action: Upgrade to 9.2.9 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
Publify before 8.0.1 is vulnerable to a Denial of Service attack
Recommended action: Upgrade to 8.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
Leaking password protected articles content due to improper access control in GitHub repository publify/publify prior to 9.2.8. Attackers can leverage this vulnerability to view the contents of any password-protected article present on the publify website, compromising confidentiality and integrity of users.
Recommended action: Upgrade to 9.2.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
Code Injection in GitHub repository publify/publify prior to 9.2.8.
Recommended action: Upgrade to 9.2.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
Improper Access Control in GitHub repository publify/publify prior to 9.2.8. Anonymous users can't view but can leave comments on an article in draft mode.
Recommended action: Upgrade to 9.2.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
Publify (formerly known as Typo) prior to version 9.2.7 is vulnerable to business logic errors.
Recommended action: Upgrade to 9.2.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
In Publify, 9.0.0.pre1 to 9.2.4 are vulnerable to Improper Access Control. guest role users can self-register even when the admin does not allow it. This happens due to front-end restriction only.
Recommended action: Upgrade to 9.2.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.