Skip to content

← Actionable
Low, CVSS 1.8

Publify Vulnerable To Cross-Site Scripting (XSS) Via Redirects Requiring User Interaction

CVE-2024-39311GHSA-8fm5-gg2f-f66q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (publify_core 10.0.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
1.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P · score source
EPSS
  • CVE-2024-39311: 0.27% estimated exploitation activity in the next 30 days; percentile 19.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A publisher on a publify application is able to perform a cross-site scripting attack on an administrator using the redirect functionality. Details A publisher on a publify application is able to perform a cross-site scripting attack on an administrator using the redirect functionality. The exploitation of this XSS vulnerability requires the administrator to click a malicious link. We can create a redirect to a javascript:alert() URL. Whilst the redirect itself doesn't work, on the administrative panel, an a tag is created with the payload as the URI. Upon clicking this link, the XSS is triggered. An attack could attempt to hide their payload by using HTML, or other encodings, as to not make it obvious to an administrator that this is a malicious link. PoC A publisher can create a new redirect as shown below. The payload used is javascript:alert(). An administrator will now see this redirect in their overview of the page. If they click the link on the right, it triggers the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-8fm5-gg2f-f66q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-39311

Advisory: Publify Vulnerable To Cross-Site Scripting (XSS) Via Redirects Requiring User Interaction
IDs: CVE-2024-39311, GHSA-8fm5-gg2f-f66q
Record: https://patchnext.com/advisories/cve-2024-39311 (revision 1, source checked 26 Oct 2026, 15:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 1.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: publify_core 10.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems publify_core: affected < 10.0.2; fixed in 10.0.2

## Suggested inspection (read-only)
- RubyGems publify_core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on publify_core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8fm5-gg2f-f66q (GitHub-reviewed advisory GHSA-8fm5-gg2f-f66q lists affected ranges: RubyGems publify_core >=0 <10.0.2)

Commands are suggestions: review each one before running it.

Loading voting…