High, CVSS 8.8RubyGemsPublished
opensearch-ruby 2.x before 2.0.2 vulnerable to unsafe YAML deserialization
CVE-2022-31115 · GHSA-977c-63xq-cgw3
- Affected
- RubyGems opensearch-ruby >= 2.0.0, < 2.0.2
- Fixed in
- 2.0.2· Vendor fix available
- Issue
- Impact A YAML deserialization in opensearch-ruby 2.0.0 can lead to unsafe deserialization using YAML.load if the response is of type YAML. Patches The problem has been patched in opensearch-ruby gem version 2.0.2. Workarounds No viable workaround. Please upgrade to 2.0.2 References https://github.com/opensearch-project/opensearch-ruby/pull/77 https://staaldraad.github.io/post/2021-01-09-universal-rce-ruby-yaml-load-updated/ For more information If you have any questions or comments about this advisory: Open an issue in opensearch-ruby
Recommended action: Upgrade to 2.0.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.