opensearch-ruby 2.x before 2.0.2 vulnerable to unsafe YAML deserialization
CVE-2022-31115GHSA-977c-63xq-cgw3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (opensearch-ruby 2.0.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems opensearch-ruby
- Affected
- >= 2.0.0, < 2.0.2
- Fixed in
- 2.0.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-977c-63xq-cgw3 lists affected ranges: RubyGems opensearch-ruby >=2.0.0 <2.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-31115: 1.62% estimated exploitation activity in the next 30 days; percentile 76.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A YAML deserialization in opensearch-ruby 2.0.0 can lead to unsafe deserialization using YAML.load if the response is of type YAML. Patches The problem has been patched in opensearch-ruby gem version 2.0.2. Workarounds No viable workaround. Please upgrade to 2.0.2 References https://github.com/opensearch-project/opensearch-ruby/pull/77 https://staaldraad.github.io/post/2021-01-09-universal-rce-ruby-yaml-load-updated/ For more information If you have any questions or comments about this advisory: Open an issue in opensearch-ruby
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-977c-63xq-cgw3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-31115 Advisory: opensearch-ruby 2.x before 2.0.2 vulnerable to unsafe YAML deserialization IDs: CVE-2022-31115, GHSA-977c-63xq-cgw3 Record: https://patchnext.com/advisories/cve-2022-31115 (revision 1, source checked 26 Oct 2026, 15:44 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: opensearch-ruby 2.0.2. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems opensearch-ruby: affected >= 2.0.0, < 2.0.2; fixed in 2.0.2 ## Suggested inspection (read-only) - RubyGems opensearch-ruby: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on opensearch-ruby. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-977c-63xq-cgw3 (GitHub-reviewed advisory GHSA-977c-63xq-cgw3 lists affected ranges: RubyGems opensearch-ruby >=2.0.0 <2.0.2) Commands are suggestions: review each one before running it.
Loading voting…