Skip to content

← Public intelligence

RubyGems package

omniauth-saml

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratedRubyGemsPublished

    omniauth-saml has dependency on ruby-saml version with Signature Wrapping Attack issue

    GHSA-hw46-3hmr-x9xv

    Affected
    • RubyGems omniauth-saml >= 2.2.0, < 2.2.3; >= 2.0.0, < 2.1.3; < 1.10.6
    Fixed in
    1.10.62.1.32.2.3· Vendor fix available
    Issue
    There are 2 new Critical Signature Wrapping Vulnerabilities (CVE-2025-25292, CVE-2025-25291) and a potential DDOS Moderated Vulneratiblity (CVE-2025-25293) affecting ruby-saml, a dependency of omniauth-saml. The fix will be applied to ruby-saml and released 12 March 2025, under version 1.18.0. Please upgrade the ruby-saml requirement to v1.18.0. Impact Signature Wrapping Vulnerabilities allows an attacker to impersonate a user.

    Recommended action: Upgrade to 2.2.3, 2.1.3 or 1.10.6 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.9RubyGemsPublished

    omniauth-saml vulnerable to Improper Verification of Cryptographic Signature

    GHSA-cvp8-5r8g-fhvq

    Affected
    • RubyGems omniauth-saml >= 2.0.0, < 2.1.2; < 1.10.5; >= 2.2.0, < 2.2.1
    Fixed in
    1.10.52.1.22.2.1· Vendor fix available
    Issue
    ruby-saml, the dependent SAML gem of omniauth-saml has a signature wrapping vulnerability in <= v1.12.0 and v1.13.0 to v1.16.0 , see https://github.com/SAML-Toolkits/ruby-saml/security/advisories/GHSA-jw9c-mfg7-9rx2 As a result, omniauth-saml created a new release by upgrading ruby-saml to the patched versions v1.17.

    Recommended action: Upgrade to 2.2.1, 2.1.2 or 1.10.5 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 7.7RubyGemsPublished

    OmniAuth-SAML authentication bypass via incorrect XML canonicalization and DOM traversal

    CVE-2017-11430 · GHSA-94hm-8q65-rmxm

    Affected
    • RubyGems omniauth-saml < 1.10.0
    Fixed in
    1.10.0· Vendor fix available
    Issue
    OmniAuth OmniAuth-SAML 1.9.0 and earlier may incorrectly utilize the results of XML DOM traversal and canonicalization APIs in such a way that an attacker may be able to manipulate the SAML data without invalidating the cryptographic signature, allowing the attack to potentially bypass authentication to SAML service providers.

    Recommended action: Upgrade to 1.10.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →