Skip to content

← Actionable
Critical, CVSS 9.9

omniauth-saml vulnerable to Improper Verification of Cryptographic Signature

GHSA-cvp8-5r8g-fhvq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (omniauth-saml 2.2.1, 2.1.2, 1.10.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems omniauth-saml

    Affected
    >= 2.0.0, < 2.1.2< 1.10.5>= 2.2.0, < 2.2.1
    Fixed in
    1.10.5, 2.1.2, 2.2.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

ruby-saml, the dependent SAML gem of omniauth-saml has a signature wrapping vulnerability in <= v1.12.0 and v1.13.0 to v1.16.0 , see https://github.com/SAML-Toolkits/ruby-saml/security/advisories/GHSA-jw9c-mfg7-9rx2 As a result, omniauth-saml created a new release by upgrading ruby-saml to the patched versions v1.17.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-cvp8-5r8g-fhvq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-cvp8-5r8g-fhvq

Advisory: omniauth-saml vulnerable to Improper Verification of Cryptographic Signature
IDs: GHSA-cvp8-5r8g-fhvq
Record: https://patchnext.com/advisories/ghsa-cvp8-5r8g-fhvq (revision 1, source checked 26 Oct 2026, 15:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: omniauth-saml 2.2.1, 2.1.2, 1.10.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems omniauth-saml: affected >= 2.0.0, < 2.1.2; < 1.10.5; >= 2.2.0, < 2.2.1; fixed in 1.10.5, 2.1.2, 2.2.1

## Suggested inspection (read-only)
- RubyGems omniauth-saml: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on omniauth-saml.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cvp8-5r8g-fhvq (GitHub-reviewed advisory GHSA-cvp8-5r8g-fhvq lists affected ranges: RubyGems omniauth-saml >=2.0.0 =0 =2.2.0 <2.2.1)

Commands are suggestions: review each one before running it.

Loading voting…