High, CVSS 7.5RubyGemsPublished
mixlib-archive Path Traversal vulnerability
CVE-2017-1000026 · GHSA-98wx-cw86-c97x
- Affected
- RubyGems mixlib-archive < 0.4.0
- Fixed in
- 0.4.0· Vendor fix available
- Issue
- Chef Software's mixlib-archive versions 0.3.0 and older are vulnerable to a directory traversal attack allowing attackers to overwrite arbitrary files by using .. in tar archive entries
Recommended action: Upgrade to 0.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.