Skip to content

← Actionable
High, CVSS 7.5

mixlib-archive Path Traversal vulnerability

CVE-2017-1000026GHSA-98wx-cw86-c97x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mixlib-archive 0.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2017-1000026: 1.90% estimated exploitation activity in the next 30 days; percentile 79.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Chef Software's mixlib-archive versions 0.3.0 and older are vulnerable to a directory traversal attack allowing attackers to overwrite arbitrary files by using .. in tar archive entries

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-98wx-cw86-c97x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-1000026

Advisory: mixlib-archive Path Traversal vulnerability
IDs: CVE-2017-1000026, GHSA-98wx-cw86-c97x
Record: https://patchnext.com/advisories/cve-2017-1000026 (revision 1, source checked 26 Oct 2026, 15:44 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mixlib-archive 0.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems mixlib-archive: affected < 0.4.0; fixed in 0.4.0

## Suggested inspection (read-only)
- RubyGems mixlib-archive: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mixlib-archive.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-98wx-cw86-c97x (GitHub-reviewed advisory GHSA-98wx-cw86-c97x lists affected ranges: RubyGems mixlib-archive >=0 <0.4.0)

Commands are suggestions: review each one before running it.

Loading voting…