Skip to content

← Public intelligence

RubyGems package

mini_magick

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.8RubyGemsPublished

    OS Command Injection in MiniMagick

    CVE-2019-13574 · GHSA-r7j3-vvh2-xrpj

    Affected
    • RubyGems mini_magick < 4.9.4
    Fixed in
    4.9.4· Vendor fix available
    Issue
    In lib/minimagick/image.rb in MiniMagick before 4.9.4, a fetched remote image filename could cause remote command execution because Image.open input is directly passed to Kernel#open, which accepts a | character followed by a command.

    Recommended action: Upgrade to 4.9.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. UnratedRubyGemsPublished

    MiniMagick Gem for Ruby URI Handling Arbitrary Command Injection

    CVE-2013-2616 · GHSA-w754-gq8r-pf5f

    Affected
    • RubyGems mini_magick < 3.6.0
    Fixed in
    3.6.0· Vendor fix available
    Issue
    lib/minimagick.rb in the MiniMagick Gem 1.3.1 for Ruby allows remote attackers to execute arbitrary commands via shell metacharacters in a URL.

    Recommended action: Upgrade to 3.6.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →