OS Command Injection in MiniMagick
CVE-2019-13574GHSA-r7j3-vvh2-xrpj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mini_magick 4.9.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems mini_magick
- Affected
- < 4.9.4
- Fixed in
- 4.9.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r7j3-vvh2-xrpj lists affected ranges: RubyGems mini_magick >=0 <4.9.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.8 · CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2019-13574: 7.64% estimated exploitation activity in the next 30 days; percentile 94.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In lib/minimagick/image.rb in MiniMagick before 4.9.4, a fetched remote image filename could cause remote command execution because Image.open input is directly passed to Kernel#open, which accepts a | character followed by a command.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-r7j3-vvh2-xrpj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-13574 Advisory: OS Command Injection in MiniMagick IDs: CVE-2019-13574, GHSA-r7j3-vvh2-xrpj Record: https://patchnext.com/advisories/cve-2019-13574 (revision 1, source checked 26 Oct 2026, 15:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mini_magick 4.9.4. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems mini_magick: affected < 4.9.4; fixed in 4.9.4 ## Suggested inspection (read-only) - RubyGems mini_magick: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mini_magick. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-r7j3-vvh2-xrpj (GitHub-reviewed advisory GHSA-r7j3-vvh2-xrpj lists affected ranges: RubyGems mini_magick >=0 <4.9.4) Commands are suggestions: review each one before running it.
Loading voting…