Medium, CVSS 5.3RubyGemsPublished
Kredis JSON Possible Deserialization of Untrusted Data Vulnerability
CVE-2023-27531 · GHSA-h2wm-p2vg-6pw4
- Affected
- RubyGems kredis < 1.3.0.1
- Fixed in
- 1.3.0.1· Vendor fix available
- Issue
- There is a deserialization of untrusted data vulnerability in the Kredis JSON deserialization code. This vulnerability has been assigned the CVE identifier CVE-2023-27531. 'Not affected: None.' 'Versions Affected: All.' 'Fixed Versions: 1.3.0.1' Impact Carefully crafted JSON data processed by Kredis may result in deserialization of untrusted data, potentially leading to deserialization of unexpected objects in the system. Any applications using Kredis with JSON are affected. Releases The fixed releases are available at the normal locations. Workarounds There are no feasible workarounds for this issue. Patches To aid users who aren’t able to upgrade immediately we have provided patches for the two supported release series. They are in git-am format and consist of a single changeset. 1-3-0-1-kredis.patch - Patch for 1.3.0 series Credits Thank you oooooook 7 for reporting this!
Recommended action: Upgrade to 1.3.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.