Kredis JSON Possible Deserialization of Untrusted Data Vulnerability
CVE-2023-27531GHSA-h2wm-p2vg-6pw4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (kredis 1.3.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems kredis
- Affected
- < 1.3.0.1
- Fixed in
- 1.3.0.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h2wm-p2vg-6pw4 lists affected ranges: RubyGems kredis >=0 <1.3.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2023-27531: 0.54% estimated exploitation activity in the next 30 days; percentile 45.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
There is a deserialization of untrusted data vulnerability in the Kredis JSON deserialization code. This vulnerability has been assigned the CVE identifier CVE-2023-27531. 'Not affected: None.' 'Versions Affected: All.' 'Fixed Versions: 1.3.0.1' Impact Carefully crafted JSON data processed by Kredis may result in deserialization of untrusted data, potentially leading to deserialization of unexpected objects in the system. Any applications using Kredis with JSON are affected. Releases The fixed releases are available at the normal locations. Workarounds There are no feasible workarounds for this issue. Patches To aid users who aren’t able to upgrade immediately we have provided patches for the two supported release series. They are in git-am format and consist of a single changeset. 1-3-0-1-kredis.patch - Patch for 1.3.0 series Credits Thank you oooooook 7 for reporting this!
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-h2wm-p2vg-6pw4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-27531 Advisory: Kredis JSON Possible Deserialization of Untrusted Data Vulnerability IDs: CVE-2023-27531, GHSA-h2wm-p2vg-6pw4 Record: https://patchnext.com/advisories/cve-2023-27531 (revision 1, source checked 26 Oct 2026, 15:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: kredis 1.3.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems kredis: affected < 1.3.0.1; fixed in 1.3.0.1 ## Suggested inspection (read-only) - RubyGems kredis: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on kredis. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-h2wm-p2vg-6pw4 (GitHub-reviewed advisory GHSA-h2wm-p2vg-6pw4 lists affected ranges: RubyGems kredis >=0 <1.3.0.1) Commands are suggestions: review each one before running it.
Loading voting…