Skip to content

← Public intelligence

RubyGems package

kramdown

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8RubyGemsPublished

    Remote code execution in Kramdown

    CVE-2021-28834 · GHSA-52p9-v744-mwjj

    Affected
    • RubyGems kramdown >= 1.16.0, < 2.3.1
    Fixed in
    2.3.1· Vendor fix available
    Issue
    Kramdown before 2.3.1 does not restrict Rouge formatters to the Rouge::Formatters namespace, and thus arbitrary classes can be instantiated.

    Recommended action: Upgrade to 2.3.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.8RubyGemsPublished

    Unintended read access in kramdown gem

    CVE-2020-14001 · GHSA-mqm2-cgpr-p4m6

    Affected
    • RubyGems kramdown < 2.3.0
    Fixed in
    2.3.0· Vendor fix available
    Issue
    The kramdown gem before 2.3.0 for Ruby processes the template option inside Kramdown documents by default, which allows unintended read access (such as template="/etc/passwd") or unintended embedded Ruby code execution (such as a string that begins with template="string://<%= ). NOTE: kramdown is used in Jekyll, GitLab Pages, GitHub Pages, and Thredded Forum.

    Recommended action: Upgrade to 2.3.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →