Unintended read access in kramdown gem
CVE-2020-14001GHSA-mqm2-cgpr-p4m6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (kramdown 2.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems kramdown
- Affected
- < 2.3.0
- Fixed in
- 2.3.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mqm2-cgpr-p4m6 lists affected ranges: RubyGems kramdown >=0 <2.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2020-14001: 4.56% estimated exploitation activity in the next 30 days; percentile 91.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The kramdown gem before 2.3.0 for Ruby processes the template option inside Kramdown documents by default, which allows unintended read access (such as template="/etc/passwd") or unintended embedded Ruby code execution (such as a string that begins with template="string://<%= ). NOTE: kramdown is used in Jekyll, GitLab Pages, GitHub Pages, and Thredded Forum.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-mqm2-cgpr-p4m6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-14001 Advisory: Unintended read access in kramdown gem IDs: CVE-2020-14001, GHSA-mqm2-cgpr-p4m6 Record: https://patchnext.com/advisories/cve-2020-14001 (revision 1, source checked 26 Oct 2026, 15:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: kramdown 2.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems kramdown: affected < 2.3.0; fixed in 2.3.0 ## Suggested inspection (read-only) - RubyGems kramdown: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on kramdown. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mqm2-cgpr-p4m6 (GitHub-reviewed advisory GHSA-mqm2-cgpr-p4m6 lists affected ranges: RubyGems kramdown >=0 <2.3.0) Commands are suggestions: review each one before running it.
Loading voting…