Skip to content

← Public intelligence

RubyGems package

katello

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

7 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.3RubyGemsPublished

    katello: missing repository authorization in content_uploads exposes cross-product content existence

    CVE-2026-12515 · GHSA-c43c-rf7g-5xpg

    Affected
    • RubyGems katello < 4.21.0.rc1
    Fixed in
    4.21.0.rc1· Vendor fix available
    Issue
    A flaw was found in Katello's of Red Hat Satellite. A content upload functionality where insufficient authorization checks in the ContentUploadsController allowed users with the editproducts permission to query content information for repositories outside the products they were authorized to manage. An authenticated attacker could exploit this issue to determine whether specific content exists within repositories that should otherwise be inaccessible. This issue does not allow unauthorized modification, import, or publication of content.

    Recommended action: Upgrade to 4.21.0.rc1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 5.4RubyGemsPublished

    Katello: Denial of Service and potential information disclosure via SQL injection

    CVE-2026-4324 · GHSA-fwj4-6wgp-mpxm

    Affected
    • RubyGems katello < 4.19.1
    Fixed in
    4.19.1· Vendor fix available
    Issue
    A flaw was found in the Katello plugin for Red Hat Satellite. This vulnerability, caused by improper sanitization of user-provided input, allows a remote attacker to inject arbitrary SQL commands into the sortby parameter of the /api/hosts/bootcimages API endpoint. This can lead to a Denial of Service (DoS) by triggering database errors, and potentially enable Boolean-based Blind SQL injection, which could allow an attacker to extract sensitive information from the database.

    Recommended action: Upgrade to 4.19.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Low, CVSS 2.7RubyGemsPublished

    Katello cleartext password storage issue

    CVE-2019-14825 · GHSA-m4wh-848j-9w2r

    Affected
    • RubyGems katello >= 3.0.0.0, < 3.12.2
    Fixed in
    3.12.2· Vendor fix available
    Issue
    A cleartext password storage issue was discovered in Katello, versions 3.x.x.x before katello 3.12.2. Registry credentials used during container image discovery were inadvertently logged without being masked. This flaw could expose the registry credentials to other privileged users.

    Recommended action: Upgrade to 3.12.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Critical, CVSS 9.8RubyGemsPublished

    Katello uses hard coded credential

    CVE-2012-3503 · GHSA-5xv2-q475-rwrh

    Affected
    • RubyGems katello < 1.0.6; >= 1.1.0, < 1.1.7
    Fixed in
    1.0.61.1.7· Vendor fix available
    Issue
    The installation script in Katello 1.0 and earlier does not properly generate the Application.config.secrettoken value, which causes each default installation to have the same secret token, and allows remote attackers to authenticate to the CloudForms System Engine web interface as an arbitrary user by creating a cookie using the default secrettoken.

    Recommended action: Upgrade to 1.1.7 or 1.0.6 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. High, CVSS 8.8RubyGemsPublished

    Katello SQL Injection vulnerabilities

    CVE-2016-3072 · GHSA-527r-mfmj-prqf

    Affected
    • RubyGems katello < 2.4.3
    Fixed in
    2.4.3· Vendor fix available
    Issue
    Multiple SQL injection vulnerabilities in the scopedsearch function in app/controllers/katello/api/v2/apicontroller.rb in Katello allow remote authenticated users to execute arbitrary SQL commands via the (1) sortby or (2) sortorder parameter.

    Recommended action: Upgrade to 2.4.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. Medium, CVSS 5.4RubyGemsPublished

    katello Cross-site Scripting vulnerability

    CVE-2018-16887 · GHSA-mhhc-r88h-2qrm

    Affected
    • RubyGems katello < 3.9.0
    Fixed in
    3.9.0· Vendor fix available
    Issue
    A cross-site scripting (XSS) flaw was found in the katello component of Satellite. An attacker with privilege to create/edit organizations and locations is able to execute a XSS attacks against other users through the Subscriptions or the Red Hat Repositories wizards. This can possibly lead to malicious code execution and extraction of the anti-CSRF token of higher privileged users. Versions before 3.9.0 are vulnerable.

    Recommended action: Upgrade to 3.9.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  7. Medium, CVSS 4.3RubyGemsPublished

    katello Improper Privilege Management vulnerability

    CVE-2017-2662 · GHSA-cpv6-pfq6-j2v7

    Affected
    • RubyGems katello < 3.17.0.rc1
    Fixed in
    3.17.0.rc1· Vendor fix available
    Issue
    A flaw was found in Foreman's katello plugin version 3.4.5. After setting a new role to allow restricted access on a repository with a filter (filter set on the Product Name), the filter is not respected when the actions are done via hammer using the repository id.

    Recommended action: Upgrade to 3.17.0.rc1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →