Katello uses hard coded credential
CVE-2012-3503GHSA-5xv2-q475-rwrh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (katello 1.1.7, 1.0.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems katello
- Affected
- < 1.0.6>= 1.1.0, < 1.1.7
- Fixed in
- 1.0.6, 1.1.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5xv2-q475-rwrh lists affected ranges: RubyGems katello >=0 =1.1.0 <1.1.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2012-3503: 3.00% estimated exploitation activity in the next 30 days; percentile 87.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The installation script in Katello 1.0 and earlier does not properly generate the Application.config.secrettoken value, which causes each default installation to have the same secret token, and allows remote attackers to authenticate to the CloudForms System Engine web interface as an arbitrary user by creating a cookie using the default secrettoken.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5xv2-q475-rwrh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2012-3503 Advisory: Katello uses hard coded credential IDs: CVE-2012-3503, GHSA-5xv2-q475-rwrh Record: https://patchnext.com/advisories/cve-2012-3503 (revision 1, source checked 26 Oct 2026, 15:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: katello 1.1.7, 1.0.6. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems katello: affected < 1.0.6; >= 1.1.0, < 1.1.7; fixed in 1.0.6, 1.1.7 ## Suggested inspection (read-only) - RubyGems katello: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on katello. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5xv2-q475-rwrh (GitHub-reviewed advisory GHSA-5xv2-q475-rwrh lists affected ranges: RubyGems katello >=0 =1.1.0 <1.1.7) Commands are suggestions: review each one before running it.
Loading voting…