Skip to content

← Public intelligence

RubyGems package

kaminari

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.6RubyGemsPublished

    Kaminari Insecure File Permissions Vulnerability

    CVE-2024-32978 · GHSA-7r3j-qmr4-jfpj

    Affected
    • RubyGems kaminari >= 0.15.0, <= 0.16.1
    Fixed in
    0.16.2· Vendor fix available
    Issue
    A moderate severity security vulnerability has been identified in the Kaminari pagination library for Ruby on Rails, concerning insecure file permissions. This advisory outlines the vulnerability, affected versions, and provides guidance for mitigation. Impact This vulnerability is of moderate severity due to the potential for unauthorized write access to particular Ruby files managed by the library. Such access could lead to the alteration of application behavior or data integrity issues. Resolution Those who use the gem install command, such as gem install kaminari -v 0.16.1, gem unpack kaminari -v 0.16.1, or bundle install to download the package would not be affected and no action is required. Those who manually download and decompressing the affected versions are advised to update to 0.16.2 or later version of Kaminari where file permissions have been adjusted to enhance security. Workarounds If upgrading is not feasible immediately, manually adjusting the file permissions on…

    Recommended action: Upgrade to 0.16.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 6.4RubyGemsPublished

    Cross-Site Scripting in Kaminari

    CVE-2020-11082 · GHSA-r5jw-62xg-j433

    Affected
    • RubyGems kaminari < 1.2.1
    Fixed in
    1.2.1· Vendor fix available
    Issue
    Impact In Kaminari before 1.2.1, there is a vulnerability that would allow an attacker to inject arbitrary code into pages with pagination links. This has been fixed in 1.2.1. Releases The 1.2.1 gem including the patch has already been released. All past released versions are affected by this vulnerability. Workarounds Application developers who can't update the gem can workaround by overriding the PARAMKEYEXCEPTLIST constant. Credits Thanks to Daniel Mircea for finding the issue and sending a patch via GitHub. Also thanks to Aditya Prakash for reporting the vulnerability.

    Recommended action: Upgrade to 1.2.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →