Skip to content

← Actionable
Medium, CVSS 6.4

Cross-Site Scripting in Kaminari

CVE-2020-11082GHSA-r5jw-62xg-j433

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (kaminari 1.2.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems kaminari

    Affected
    < 1.2.1
    Fixed in
    1.2.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:L/A:L
EPSS
  • CVE-2020-11082: 1.55% estimated exploitation activity in the next 30 days; percentile 75.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact In Kaminari before 1.2.1, there is a vulnerability that would allow an attacker to inject arbitrary code into pages with pagination links. This has been fixed in 1.2.1. Releases The 1.2.1 gem including the patch has already been released. All past released versions are affected by this vulnerability. Workarounds Application developers who can't update the gem can workaround by overriding the PARAMKEYEXCEPTLIST constant. Credits Thanks to Daniel Mircea for finding the issue and sending a patch via GitHub. Also thanks to Aditya Prakash for reporting the vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-r5jw-62xg-j433

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-11082

Advisory: Cross-Site Scripting in Kaminari
IDs: CVE-2020-11082, GHSA-r5jw-62xg-j433
Record: https://patchnext.com/advisories/cve-2020-11082 (revision 1, source checked 26 Oct 2026, 15:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: kaminari 1.2.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems kaminari: affected < 1.2.1; fixed in 1.2.1

## Suggested inspection (read-only)
- RubyGems kaminari: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on kaminari.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-r5jw-62xg-j433 (GitHub-reviewed advisory GHSA-r5jw-62xg-j433 lists affected ranges: RubyGems kaminari >=0 <1.2.1)

Commands are suggestions: review each one before running it.

Loading voting…