UnratedRubyGemsPublished
jquery-rails and jquery-ujs subject to Exposure of Sensitive Information
CVE-2015-1840 · GHSA-4whc-pp4x-9pf3
- Affected
- RubyGems jquery-ujs < 1.0.4
- Fixed in
- 1.0.4· Vendor fix available
- Issue
- jqueryujs.js in jquery-rails before 3.1.3 and 4.x before 4.0.4 and rails.js in jquery-ujs before 1.0.4, as used with Ruby on Rails 3.x and 4.x, allow remote attackers to bypass the Same Origin Policy, and trigger transmission of a CSRF token to a different-domain web server, via a leading space character in a URL within an attribute value.
Recommended action: Upgrade to 1.0.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.