Skip to content

← Actionable
Unrated

jquery-rails and jquery-ujs subject to Exposure of Sensitive Information

CVE-2015-1840GHSA-4whc-pp4x-9pf3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (jquery-ujs 1.0.4; jquery-rails 4.0.4, 3.1.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems jquery-ujs

    Affected
    < 1.0.4
    Fixed in
    1.0.4
  • RubyGems jquery-rails

    Affected
    < 3.1.3>= 4.0.0, < 4.0.4
    Fixed in
    3.1.3, 4.0.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2015-1840: 4.52% estimated exploitation activity in the next 30 days; percentile 91.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

jqueryujs.js in jquery-rails before 3.1.3 and 4.x before 4.0.4 and rails.js in jquery-ujs before 1.0.4, as used with Ruby on Rails 3.x and 4.x, allow remote attackers to bypass the Same Origin Policy, and trigger transmission of a CSRF token to a different-domain web server, via a leading space character in a URL within an attribute value.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4whc-pp4x-9pf3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2015-1840

Advisory: jquery-rails and jquery-ujs subject to Exposure of Sensitive Information
IDs: CVE-2015-1840, GHSA-4whc-pp4x-9pf3
Record: https://patchnext.com/advisories/cve-2015-1840 (revision 1, source checked 26 Oct 2026, 15:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: jquery-ujs 1.0.4; jquery-rails 4.0.4, 3.1.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems jquery-ujs: affected < 1.0.4; fixed in 1.0.4
- RubyGems jquery-rails: affected < 3.1.3; >= 4.0.0, < 4.0.4; fixed in 3.1.3, 4.0.4

## Suggested inspection (read-only)
- RubyGems jquery-ujs: check the installed version with your package manager.
- RubyGems jquery-rails: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on jquery-ujs, jquery-rails.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4whc-pp4x-9pf3 (GitHub-reviewed advisory GHSA-4whc-pp4x-9pf3 lists affected ranges: RubyGems jquery-rails >=0 =4.0.0 =0 <1.0.4)

Commands are suggestions: review each one before running it.

Loading voting…