Skip to content

← Public intelligence

RubyGems package

job-iteration

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.3RubyGemsPublished

    Job Iteration API is vulnerable to OS Command Injection attack through its CsvEnumerator class

    CVE-2025-53623 · GHSA-6qjf-g333-pv38

    Affected
    • RubyGems job-iteration < 1.11
    Fixed in
    1.11· Vendor fix available
    Issue
    Impact There is an arbitrary code execution vulnerability in the CsvEnumerator class of the job-iteration repository. This vulnerability can be exploited by an attacker to execute arbitrary commands on the system where the application is running, potentially leading to unauthorized access, data leakage, or complete system compromise. Patches Issue is fixed in versions 1.11.0 and above. Workarounds Users can mitigate the risk by avoiding the use of untrusted input in the CsvEnumerator class and ensuring that any file paths are properly sanitized and validated before being passed to the class methods. Users should avoid calling countofrowsinfile on enumerators constructed with untrusted CSV filenames.

    Recommended action: Upgrade to 1.11 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →