Job Iteration API is vulnerable to OS Command Injection attack through its CsvEnumerator class
CVE-2025-53623GHSA-6qjf-g333-pv38
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (job-iteration 1.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems job-iteration
- Affected
- < 1.11
- Fixed in
- 1.11
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6qjf-g333-pv38 lists affected ranges: RubyGems job-iteration >=0 <1.11
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-53623: 0.83% estimated exploitation activity in the next 30 days; percentile 57.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact There is an arbitrary code execution vulnerability in the CsvEnumerator class of the job-iteration repository. This vulnerability can be exploited by an attacker to execute arbitrary commands on the system where the application is running, potentially leading to unauthorized access, data leakage, or complete system compromise. Patches Issue is fixed in versions 1.11.0 and above. Workarounds Users can mitigate the risk by avoiding the use of untrusted input in the CsvEnumerator class and ensuring that any file paths are properly sanitized and validated before being passed to the class methods. Users should avoid calling countofrowsinfile on enumerators constructed with untrusted CSV filenames.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6qjf-g333-pv38
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-53623 Advisory: Job Iteration API is vulnerable to OS Command Injection attack through its CsvEnumerator class IDs: CVE-2025-53623, GHSA-6qjf-g333-pv38 Record: https://patchnext.com/advisories/cve-2025-53623 (revision 1, source checked 26 Oct 2026, 15:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: job-iteration 1.11. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems job-iteration: affected < 1.11; fixed in 1.11 ## Suggested inspection (read-only) - RubyGems job-iteration: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on job-iteration. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6qjf-g333-pv38 (GitHub-reviewed advisory GHSA-6qjf-g333-pv38 lists affected ranges: RubyGems job-iteration >=0 <1.11) Commands are suggestions: review each one before running it.
Loading voting…