Skip to content

← Public intelligence

RubyGems package

i18n

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5RubyGemsPublished

    i18n Vulnerable to Denial of Service Attack

    CVE-2014-10077 · GHSA-34hf-g744-jw64

    Affected
    • RubyGems i18n < 0.8.0
    Fixed in
    0.8.0· Vendor fix available
    Issue
    Hash#slice in lib/i18n/coreext/hash.rb in the i18n gem before 0.8.0 for Ruby allows remote attackers to cause a denial of service (application crash) via a call in a situation where :somekey is present in keepkeys but not present in the hash.

    Recommended action: Upgrade to 0.8.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. UnratedRubyGemsPublished

    i18n gem Cross-site Scripting vulnerability

    CVE-2013-4492 · GHSA-r5hc-9xx5-97rw

    Affected
    • RubyGems i18n < 0.6.6
    Fixed in
    0.6.6· Vendor fix available
    Issue
    Cross-site scripting (XSS) vulnerability in exceptions.rb in the i18n gem before 0.6.6 for Ruby allows remote attackers to inject arbitrary web script or HTML via a crafted I18n::MissingTranslationData.new call.

    Recommended action: Upgrade to 0.6.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →