Skip to content

← Actionable
High, CVSS 7.5

i18n Vulnerable to Denial of Service Attack

CVE-2014-10077GHSA-34hf-g744-jw64

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (i18n 0.8.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems i18n

    Affected
    < 0.8.0
    Fixed in
    0.8.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2014-10077: 3.39% estimated exploitation activity in the next 30 days; percentile 88.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Hash#slice in lib/i18n/coreext/hash.rb in the i18n gem before 0.8.0 for Ruby allows remote attackers to cause a denial of service (application crash) via a call in a situation where :somekey is present in keepkeys but not present in the hash.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-34hf-g744-jw64

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2014-10077

Advisory: i18n Vulnerable to Denial of Service Attack
IDs: CVE-2014-10077, GHSA-34hf-g744-jw64
Record: https://patchnext.com/advisories/cve-2014-10077 (revision 1, source checked 26 Oct 2026, 15:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: i18n 0.8.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems i18n: affected < 0.8.0; fixed in 0.8.0

## Suggested inspection (read-only)
- RubyGems i18n: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on i18n.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-34hf-g744-jw64 (GitHub-reviewed advisory GHSA-34hf-g744-jw64 lists affected ranges: RubyGems i18n >=0 <0.8.0)

Commands are suggestions: review each one before running it.

Loading voting…