Skip to content

← Public intelligence

RubyGems package

git

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.0RubyGemsPublished

    Code injection in ruby git

    CVE-2022-47318 · GHSA-pphf-gfrm-v32r

    Affected
    • RubyGems git < 1.13.0
    Fixed in
    1.13.0· Vendor fix available
    Issue
    ruby-git versions prior to v1.13.0 allows a remote authenticated attacker to execute an arbitrary ruby code by having a user to load a repository containing a specially crafted filename to the product. This vulnerability is different from CVE-2022-46648.

    Recommended action: Upgrade to 1.13.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 8.0RubyGemsPublished

    ruby-git has potential remote code execution vulnerability

    CVE-2022-46648 · GHSA-pfpr-3463-c6jh

    Affected
    • RubyGems git >= 1.2.0, < 1.13.0
    Fixed in
    1.13.0· Vendor fix available
    Issue
    The git gem, between versions 1.2.0 and 1.12.0, incorrectly parsed the output of the git ls-files command using eval() to unescape quoted file names. If a file name was added to the git repository contained special characters, such as \n, then the git ls-files command would print the file name in quotes and escape any special characters. If the Git#lsfiles method encountered a quoted file name it would use eval() to unquote and unescape any special characters, leading to potential remote code execution. Version 1.13.0 of the git gem was released which correctly parses any quoted file names.

    Recommended action: Upgrade to 1.13.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Critical, CVSS 9.8RubyGemsPublished

    Command injection in ruby-git

    CVE-2022-25648 · GHSA-69p6-wvmq-27gg

    Affected
    • RubyGems git < 1.11.0
    Fixed in
    1.11.0· Vendor fix available
    Issue
    The package prior to v1.11.0 is vulnerable to Command Injection via git argument injection. When calling the fetch(remote = 'origin', opts = {}) function, the remote parameter is passed to the git fetch subcommand in a way such that additional flags can be set. The additional flags can be used to perform a command injection.

    Recommended action: Upgrade to 1.11.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →