Skip to content

← Actionable
High, CVSS 8.0

ruby-git has potential remote code execution vulnerability

CVE-2022-46648GHSA-pfpr-3463-c6jh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (git 1.13.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems git

    Affected
    >= 1.2.0, < 1.13.0
    Fixed in
    1.13.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.0 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2022-46648: 1.41% estimated exploitation activity in the next 30 days; percentile 72.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The git gem, between versions 1.2.0 and 1.12.0, incorrectly parsed the output of the git ls-files command using eval() to unescape quoted file names. If a file name was added to the git repository contained special characters, such as \n, then the git ls-files command would print the file name in quotes and escape any special characters. If the Git#lsfiles method encountered a quoted file name it would use eval() to unquote and unescape any special characters, leading to potential remote code execution. Version 1.13.0 of the git gem was released which correctly parses any quoted file names.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-pfpr-3463-c6jh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-46648

Advisory: ruby-git has potential remote code execution vulnerability
IDs: CVE-2022-46648, GHSA-pfpr-3463-c6jh
Record: https://patchnext.com/advisories/cve-2022-46648 (revision 1, source checked 26 Oct 2026, 15:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: git 1.13.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems git: affected >= 1.2.0, < 1.13.0; fixed in 1.13.0

## Suggested inspection (read-only)
- RubyGems git: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on git.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pfpr-3463-c6jh (GitHub-reviewed advisory GHSA-pfpr-3463-c6jh lists affected ranges: RubyGems git >=1.2.0 <1.13.0)

Commands are suggestions: review each one before running it.

Loading voting…