Skip to content

← Public intelligence

RubyGems package

fluent-plugin-s3

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Low, CVSS 2.7RubyGemsPublished

    fluent-plugin-s3 Vulnerable to Denial of Service (DoS) via Decompression Bomb in in_s3

    CVE-2026-44162 · GHSA-xv9w-7v6q-hpjh

    Affected
    • RubyGems fluent-plugin-s3 >= 0.7.0, <= 1.8.4
    Fixed in
    1.8.5· Vendor fix available
    Issue
    The fluent-plugin-s3 plugin (specifically the ins3 input plugin) supports reading and decompressing heavily compressed files (such as gzip, lzma2, and lzop) from Amazon S3. It was discovered that the plugin read the entire decompressed payload into memory at once without enforcing a strict size limit. If an attacker has sufficient permissions to upload files to the monitored S3 bucket, they can upload a maliciously crafted, highly compressed file. When Fluentd attempts to decompress this file, it will expand to an excessive size and it will consume significant system resources. Impact This vulnerability allows for a Denial of Service (DoS) attack via memory exhaustion. The rapid memory consumption during decompression can lead to an Out-of-Memory kill of the Fluentd process by the operating system, This results in the disruption of all log collection on the affected node. Patches v1.8.5 Workarounds If an immediate upgrade is not possible, mitigate the risk by applying strict IAM…

    Recommended action: Upgrade to 1.8.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →