Skip to content

← Actionable
Low, CVSS 2.7

fluent-plugin-s3 Vulnerable to Denial of Service (DoS) via Decompression Bomb in in_s3

CVE-2026-44162GHSA-xv9w-7v6q-hpjh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fluent-plugin-s3 1.8.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
2.7 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-44162: 0.48% estimated exploitation activity in the next 30 days; percentile 41.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The fluent-plugin-s3 plugin (specifically the ins3 input plugin) supports reading and decompressing heavily compressed files (such as gzip, lzma2, and lzop) from Amazon S3. It was discovered that the plugin read the entire decompressed payload into memory at once without enforcing a strict size limit. If an attacker has sufficient permissions to upload files to the monitored S3 bucket, they can upload a maliciously crafted, highly compressed file. When Fluentd attempts to decompress this file, it will expand to an excessive size and it will consume significant system resources. Impact This vulnerability allows for a Denial of Service (DoS) attack via memory exhaustion. The rapid memory consumption during decompression can lead to an Out-of-Memory kill of the Fluentd process by the operating system, This results in the disruption of all log collection on the affected node. Patches v1.8.5 Workarounds If an immediate upgrade is not possible, mitigate the risk by applying strict IAM…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xv9w-7v6q-hpjh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44162

Advisory: fluent-plugin-s3 Vulnerable to Denial of Service (DoS) via Decompression Bomb in `in_s3`
IDs: CVE-2026-44162, GHSA-xv9w-7v6q-hpjh
Record: https://patchnext.com/advisories/cve-2026-44162 (revision 1, source checked 26 Oct 2026, 15:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fluent-plugin-s3 1.8.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems fluent-plugin-s3: affected >= 0.7.0, <= 1.8.4; fixed in 1.8.5

## Suggested inspection (read-only)
- RubyGems fluent-plugin-s3: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fluent-plugin-s3.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xv9w-7v6q-hpjh (GitHub-reviewed advisory GHSA-xv9w-7v6q-hpjh lists affected ranges: RubyGems fluent-plugin-s3 >=0.7.0 <=1.8.4)

Commands are suggestions: review each one before running it.

Loading voting…