Skip to content

← Public intelligence

RubyGems package

fluent-plugin-opentelemetry

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.3RubyGemsPublished

    fluent-plugin-opentelemetry Has Denial of Service (DoS) via Large Payloads and Decompression Bombs in in_opentelemetry

    CVE-2026-44163 · GHSA-2jc5-xhx8-qj6h

    Affected
    • RubyGems fluent-plugin-opentelemetry <= 0.5.2
    Fixed in
    0.5.3· Vendor fix available
    Issue
    The fluent-plugin-opentelemetry plugin (specifically the inopentelemetry HTTP input) lacked strict size limits on incoming requests. It was discovered that the plugin read the entire request body and decompressed payloads into memory without enforcing maximum size thresholds. If the OpenTelemetry ingestion endpoint is exposed to untrusted networks, an attacker can send an excessively large HTTP request or a maliciously crafted, highly compressed payload. When the plugin attempts to read or decompress this payload, it will expand to an excessive size and it will consume significant system resources. Impact This vulnerability allows for a Denial of Service (DoS) attack via memory exhaustion. The rapid memory consumption during decompression can easily lead to an Out-of-Memory kill of the Fluentd process by the operating system. This results in the disruption of all log collection and forwarding capabilities on the affected node. Patches v0.5.3 Workarounds If an immediate upgrade is not…

    Recommended action: Upgrade to 0.5.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →