fluent-plugin-opentelemetry Has Denial of Service (DoS) via Large Payloads and Decompression Bombs in in_opentelemetry
CVE-2026-44163GHSA-2jc5-xhx8-qj6h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (fluent-plugin-opentelemetry 0.5.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems fluent-plugin-opentelemetry
- Affected
- <= 0.5.2
- Fixed in
- 0.5.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2jc5-xhx8-qj6h lists affected ranges: RubyGems fluent-plugin-opentelemetry >=0 <=0.5.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- EPSS
- CVE-2026-44163: 0.42% estimated exploitation activity in the next 30 days; percentile 36.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The fluent-plugin-opentelemetry plugin (specifically the inopentelemetry HTTP input) lacked strict size limits on incoming requests. It was discovered that the plugin read the entire request body and decompressed payloads into memory without enforcing maximum size thresholds. If the OpenTelemetry ingestion endpoint is exposed to untrusted networks, an attacker can send an excessively large HTTP request or a maliciously crafted, highly compressed payload. When the plugin attempts to read or decompress this payload, it will expand to an excessive size and it will consume significant system resources. Impact This vulnerability allows for a Denial of Service (DoS) attack via memory exhaustion. The rapid memory consumption during decompression can easily lead to an Out-of-Memory kill of the Fluentd process by the operating system. This results in the disruption of all log collection and forwarding capabilities on the affected node. Patches v0.5.3 Workarounds If an immediate upgrade is not…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2jc5-xhx8-qj6h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44163 Advisory: fluent-plugin-opentelemetry Has Denial of Service (DoS) via Large Payloads and Decompression Bombs in `in_opentelemetry` IDs: CVE-2026-44163, GHSA-2jc5-xhx8-qj6h Record: https://patchnext.com/advisories/cve-2026-44163 (revision 1, source checked 26 Oct 2026, 15:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: fluent-plugin-opentelemetry 0.5.3. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems fluent-plugin-opentelemetry: affected <= 0.5.2; fixed in 0.5.3 ## Suggested inspection (read-only) - RubyGems fluent-plugin-opentelemetry: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on fluent-plugin-opentelemetry. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2jc5-xhx8-qj6h (GitHub-reviewed advisory GHSA-2jc5-xhx8-qj6h lists affected ranges: RubyGems fluent-plugin-opentelemetry >=0 <=0.5.2) Commands are suggestions: review each one before running it.
Loading voting…