High, CVSS 7.8RubyGemsPublished
ExifTool vulnerable to arbitrary code execution
GHSA-q95h-cqrv-8jv5
- Affected
- RubyGems exiftool_vendored < 12.25.0
- Fixed in
- 12.25.0· Vendor fix available
- Issue
- Impact Arbitrary code execution can occur when running exiftool against files with hostile metadata payloads Patches ExifTool has already been patched in version 12.24. exiftoolvendored.rb, which vendors ExifTool, includes this patch in v12.25.0. Workarounds No References https://twitter.com/wcbowling/status/1385803927321415687 https://nvd.nist.gov/vuln/detail/CVE-2021-22204 For more information If you have any questions or comments about this advisory: Open an issue in exiftoolvendored.rb
Recommended action: Upgrade to 12.25.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.