Skip to content

← Actionable
High, CVSS 7.8

ExifTool vulnerable to arbitrary code execution

GHSA-q95h-cqrv-8jv5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (exiftool_vendored 12.25.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact Arbitrary code execution can occur when running exiftool against files with hostile metadata payloads Patches ExifTool has already been patched in version 12.24. exiftoolvendored.rb, which vendors ExifTool, includes this patch in v12.25.0. Workarounds No References https://twitter.com/wcbowling/status/1385803927321415687 https://nvd.nist.gov/vuln/detail/CVE-2021-22204 For more information If you have any questions or comments about this advisory: Open an issue in exiftoolvendored.rb

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-q95h-cqrv-8jv5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-q95h-cqrv-8jv5

Advisory: ExifTool vulnerable to arbitrary code execution
IDs: GHSA-q95h-cqrv-8jv5
Record: https://patchnext.com/advisories/ghsa-q95h-cqrv-8jv5 (revision 1, source checked 26 Oct 2026, 15:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: exiftool_vendored 12.25.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems exiftool_vendored: affected < 12.25.0; fixed in 12.25.0

## Suggested inspection (read-only)
- RubyGems exiftool_vendored: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on exiftool_vendored.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q95h-cqrv-8jv5 (GitHub-reviewed advisory GHSA-q95h-cqrv-8jv5 lists affected ranges: RubyGems exiftool_vendored >=0 <12.25.0)

Commands are suggestions: review each one before running it.

Loading voting…