Critical, CVSS 9.8RubyGemsPublished
curupira is vulnerable to SQL injection
CVE-2015-10053 · GHSA-85gf-wr67-f83w
- Affected
- RubyGems curupira < 0.1.4
- Fixed in
- 0.1.4· Vendor fix available
- Issue
- A vulnerability classified as critical has been found in prodigasistemas curupira up to 0.1.3. Affected is an unknown function of the file app/controllers/curupira/passwordscontroller.rb. The manipulation leads to sql injection. Upgrading to version 0.1.4 is able to address this issue. The name of the patch is 93a9a77896bb66c949acb8e64bceafc74bc8c271. It is recommended to upgrade the affected component. VDB-218394 is the identifier assigned to this vulnerability.
Recommended action: Upgrade to 0.1.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.