Skip to content

← Actionable
Critical, CVSS 9.8

curupira is vulnerable to SQL injection

CVE-2015-10053GHSA-85gf-wr67-f83w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (curupira 0.1.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems curupira

    Affected
    < 0.1.4
    Fixed in
    0.1.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2015-10053: 0.78% estimated exploitation activity in the next 30 days; percentile 55.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability classified as critical has been found in prodigasistemas curupira up to 0.1.3. Affected is an unknown function of the file app/controllers/curupira/passwordscontroller.rb. The manipulation leads to sql injection. Upgrading to version 0.1.4 is able to address this issue. The name of the patch is 93a9a77896bb66c949acb8e64bceafc74bc8c271. It is recommended to upgrade the affected component. VDB-218394 is the identifier assigned to this vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-85gf-wr67-f83w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2015-10053

Advisory: curupira is vulnerable to SQL injection
IDs: CVE-2015-10053, GHSA-85gf-wr67-f83w
Record: https://patchnext.com/advisories/cve-2015-10053 (revision 1, source checked 26 Oct 2026, 15:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: curupira 0.1.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems curupira: affected < 0.1.4; fixed in 0.1.4

## Suggested inspection (read-only)
- RubyGems curupira: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on curupira.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-85gf-wr67-f83w (GitHub-reviewed advisory GHSA-85gf-wr67-f83w lists affected ranges: RubyGems curupira >=0 <0.1.4)

Commands are suggestions: review each one before running it.

Loading voting…