Skip to content

← Public intelligence

RubyGems package

bson

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5RubyGemsPublished

    BSON rubygem contains potential denial of service

    CVE-2015-4411 · GHSA-qh4w-7pw3-p4rp

    Affected
    • RubyGems bson < 3.0.4
    Fixed in
    3.0.4· Vendor fix available
    Issue
    The Moped::BSON::ObjecId.legal? method in mongodb/bson-ruby before 3.0.4 as used in rubygem-moped allows remote attackers to cause a denial of service (worker resource consumption) via a crafted string. NOTE: This issue is due to an incomplete fix to CVE-2015-4410.

    Recommended action: Upgrade to 3.0.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.8RubyGemsPublished

    bson is vulnerable to denial of service due to incorrect regex validation

    CVE-2015-4412 · GHSA-h6rj-8r3c-9gpj

    Affected
    • RubyGems bson >= 2.0, < 3.0.4; < 1.12.3
    Fixed in
    1.12.33.0.4· Vendor fix available
    Issue
    BSON injection vulnerability in the legal function in BSON (bson-ruby) gem before 3.0.4 for Ruby allows remote attackers to cause a denial of service (resource consumption) or inject arbitrary data via a crafted string.

    Recommended action: Upgrade to 3.0.4 or 1.12.3 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →