Skip to content

← Actionable
High, CVSS 7.5

BSON rubygem contains potential denial of service

CVE-2015-4411GHSA-qh4w-7pw3-p4rp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (bson 3.0.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems bson

    Affected
    < 3.0.4
    Fixed in
    3.0.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2015-4411: 6.37% estimated exploitation activity in the next 30 days; percentile 93.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The Moped::BSON::ObjecId.legal? method in mongodb/bson-ruby before 3.0.4 as used in rubygem-moped allows remote attackers to cause a denial of service (worker resource consumption) via a crafted string. NOTE: This issue is due to an incomplete fix to CVE-2015-4410.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-qh4w-7pw3-p4rp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2015-4411

Advisory: BSON rubygem contains potential denial of service
IDs: CVE-2015-4411, GHSA-qh4w-7pw3-p4rp
Record: https://patchnext.com/advisories/cve-2015-4411 (revision 1, source checked 26 Oct 2026, 15:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: bson 3.0.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems bson: affected < 3.0.4; fixed in 3.0.4

## Suggested inspection (read-only)
- RubyGems bson: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on bson.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qh4w-7pw3-p4rp (GitHub-reviewed advisory GHSA-qh4w-7pw3-p4rp lists affected ranges: RubyGems bson >=0 <3.0.4)

Commands are suggestions: review each one before running it.

Loading voting…