Skip to content

← Public intelligence

RubyGems package

actiontext

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.6RubyGemsPublished

    Possible ReDoS vulnerability in plain_text_for_blockquote_node in Action Text

    CVE-2024-47888 · GHSA-wwhv-wxv9-rpgw

    Affected
    • RubyGems actiontext >= 6.0.0, < 6.1.7.9; >= 7.0.0, < 7.0.8.5; >= 7.1.0, < 7.1.4.1; >= 7.2.0, < 7.2.1.1
    Fixed in
    7.0.8.57.1.4.17.2.1.16.1.7.9· Vendor fix available
    Issue
    There is a possible ReDoS vulnerability in the plaintextforblockquotenode helper in Action Text. This vulnerability has been assigned the CVE identifier CVE-2024-47888. Impact ------ Carefully crafted text can cause the plaintextforblockquotenode helper to take an unexpected amount of time, possibly resulting in a DoS vulnerability. All users running an affected release should either upgrade or apply the relevant patch immediately. Ruby 3.2 has mitigations for this problem, so Rails applications using Ruby 3.2 or newer are unaffected. Rails 8.0.0.beta1 depends on Ruby 3.2 or greater so is unaffected. Releases -------- The fixed releases are available at the normal locations. Workarounds ----------- Users can avoid calling plaintextforblockquotenode or upgrade to Ruby 3.2 Credits ------- Thanks to oooooooq for the report!

    Recommended action: Upgrade to 7.2.1.1, 7.1.4.1, 7.0.8.5 or 6.1.7.9 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 5.1RubyGemsPublished

    ActionText ContentAttachment can Contain Unsanitized HTML

    CVE-2024-32464 · GHSA-prjp-h48f-jgf6

    Affected
    • RubyGems actiontext >= 7.1.0, < 7.1.3.4; >= 7.2.0.beta1, <= 7.2.0.beta1
    Fixed in
    7.2.0.beta27.1.3.4· Vendor fix available
    Issue
    Instances of ActionText::Attachable::ContentAttachment included within a richtextarea tag could potentially contain unsanitized HTML. This has been assigned the CVE identifier CVE-2024-32464. Versions Affected: = 7.1.0 Not affected: < 7.1.0 Fixed Versions: 7.1.3.4 Impact ------ This could lead to a potential cross site scripting issue within the Trix editor. Releases -------- The fixed releases are available at the normal locations. Workarounds ----------- N/A Patches ------- To aid users who aren't able to upgrade immediately we have provided patches for the supported release series in accordance with our maintenance policy regarding security issues. They are in git-am format and consist of a single changeset. actiontextcontentattachmentxss71stable.patch - Patch for 7.1 series Credits ------- Thank you oooooooq for reporting this!

    Recommended action: Upgrade to 7.2.0.beta2 or 7.1.3.4 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 5.4RubyGemsAmendedPublished

    Trix Editor Arbitrary Code Execution Vulnerability

    CVE-2024-34341 · GHSA-qjqp-xr96-cj99

    Affected
    • RubyGems actiontext >= 7.0.0.alpha1, < 7.0.8.3; >= 7.1.0.beta1, < 7.1.3.3
    Fixed in
    7.1.3.37.0.8.3· Vendor fix available
    Issue
    The Trix editor, versions prior to 2.1.1, is vulnerable to arbitrary code execution when copying and pasting content from the web or other documents with markup into the editor. The vulnerability stems from improper sanitization of pasted content, allowing an attacker to embed malicious scripts which are executed within the context of the application. Vulnerable Versions: - 1.x series up to and including 1.3.1 - 2.x series up to and including 2.1.0 Fixed Versions: - v1.3.2 - v2.1.1 Vector: - Bug 1: When copying content manipulated by a script, such as: and pasting into the Trix editor, the script within the content is executed. - Bug 2: Similar execution occurs with content structured as: Impact: An attacker could exploit these vulnerabilities to execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed. Remediation: Update Recommendation: Users should upgrade to…

    Recommended action: Upgrade to 7.1.3.3 or 7.0.8.3 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →