Skip to content

← Actionable
Medium, CVSS 5.4amended

Trix Editor Arbitrary Code Execution Vulnerability

CVE-2024-34341GHSA-qjqp-xr96-cj99

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (trix 2.1.1, 1.3.2; actiontext 7.1.3.3, 7.0.8.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm trix

    Affected
    >= 2.0.0, < 2.1.1>= 0.9.0, < 1.3.2
    Fixed in
    2.1.1, 1.3.2
  • RubyGems actiontext

    Affected
    >= 7.0.0.alpha1, < 7.0.8.3>= 7.1.0.beta1, < 7.1.3.3
    Fixed in
    7.1.3.3, 7.0.8.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
EPSS
  • CVE-2024-34341: 0.78% estimated exploitation activity in the next 30 days; percentile 56.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The Trix editor, versions prior to 2.1.1, is vulnerable to arbitrary code execution when copying and pasting content from the web or other documents with markup into the editor. The vulnerability stems from improper sanitization of pasted content, allowing an attacker to embed malicious scripts which are executed within the context of the application. Vulnerable Versions: - 1.x series up to and including 1.3.1 - 2.x series up to and including 2.1.0 Fixed Versions: - v1.3.2 - v2.1.1 Vector: - Bug 1: When copying content manipulated by a script, such as: and pasting into the Trix editor, the script within the content is executed. - Bug 2: Similar execution occurs with content structured as: Impact: An attacker could exploit these vulnerabilities to execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed. Remediation: Update Recommendation: Users should upgrade to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-qjqp-xr96-cj99

  2. Revision 1 · created ·

    Published from osv record GHSA-qjqp-xr96-cj99

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-34341

Advisory: Trix Editor Arbitrary Code Execution Vulnerability
IDs: CVE-2024-34341, GHSA-qjqp-xr96-cj99
Record: https://patchnext.com/advisories/cve-2024-34341 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: trix 2.1.1, 1.3.2; actiontext 7.1.3.3, 7.0.8.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm trix: affected >= 2.0.0, < 2.1.1; >= 0.9.0, < 1.3.2; fixed in 2.1.1, 1.3.2
- RubyGems actiontext: affected >= 7.0.0.alpha1, < 7.0.8.3; >= 7.1.0.beta1, < 7.1.3.3; fixed in 7.1.3.3, 7.0.8.3

## Suggested inspection (read-only)
- `npm ls trix --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- RubyGems actiontext: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on trix, actiontext.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qjqp-xr96-cj99 (OSV record GHSA-qjqp-xr96-cj99 lists affected ranges: npm trix >=2.0.0 =0.9.0 =7.0.0.alpha1 =7.1.0.beta1 <7.1.3.3 (fixed))
- Verified: https://github.com/advisories/GHSA-qjqp-xr96-cj99 (GitHub-reviewed advisory GHSA-qjqp-xr96-cj99 lists affected ranges: npm trix >=2.0.0 =0.9.0 =7.0.0.alpha1 =7.1.0.beta1 <7.1.3.3)

Commands are suggestions: review each one before running it.

Loading voting…