Skip to content

← Public intelligence

Packagist package

zoujingli/thinkadmin

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8PackagistPublished

    ThinkAdmin insecure unserialize vulnerability

    CVE-2020-23653 · GHSA-4vp2-mj4m-69m4

    Affected
    • Packagist zoujingli/thinkadmin >= 4.0, < 6.1.0
    Fixed in
    6.1.0· Vendor fix available
    Issue
    An insecure unserialize vulnerability was discovered in ThinkAdmin versions 4.x through 6.x in app/admin/controller/api/Update.php and app/wechat/controller/api/Push.php, which may lead to arbitrary remote code execution.

    Recommended action: Upgrade to 6.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 5.4PackagistPublished

    Cross-site scripting in ThinkAdmin

    CVE-2020-29315 · GHSA-v47f-vp3p-5j6h

    Affected
    • Packagist zoujingli/thinkadmin < 6.0.22
    Fixed in
    6.0.22· Vendor fix available
    Issue
    ThinkAdmin version v6 has a stored XSS vulnerability which allows remote attackers to inject an arbitrary web script or HTML.

    Recommended action: Upgrade to 6.0.22 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →