Cross-site scripting in ThinkAdmin
CVE-2020-29315GHSA-v47f-vp3p-5j6h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (zoujingli/thinkadmin 6.0.22), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist zoujingli/thinkadmin
- Affected
- < 6.0.22
- Fixed in
- 6.0.22
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v47f-vp3p-5j6h lists affected ranges: Packagist zoujingli/thinkadmin >=0 <6.0.22
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2020-29315: 1.03% estimated exploitation activity in the next 30 days; percentile 63.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
ThinkAdmin version v6 has a stored XSS vulnerability which allows remote attackers to inject an arbitrary web script or HTML.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-v47f-vp3p-5j6h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-29315 Advisory: Cross-site scripting in ThinkAdmin IDs: CVE-2020-29315, GHSA-v47f-vp3p-5j6h Record: https://patchnext.com/advisories/cve-2020-29315 (revision 1, source checked 26 Oct 2026, 14:33 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: zoujingli/thinkadmin 6.0.22. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist zoujingli/thinkadmin: affected < 6.0.22; fixed in 6.0.22 ## Suggested inspection (read-only) - Packagist zoujingli/thinkadmin: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on zoujingli/thinkadmin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-v47f-vp3p-5j6h (GitHub-reviewed advisory GHSA-v47f-vp3p-5j6h lists affected ranges: Packagist zoujingli/thinkadmin >=0 <6.0.22) Commands are suggestions: review each one before running it.
Loading voting…