Skip to content

← Public intelligence

Packagist package

zendframework/zend-diactoros

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.7PackagistPublished

    Zend-Diactoros URL Rewrite vulnerability

    GHSA-fq4p-86hh-42v9

    Affected
    • Packagist zendframework/zend-diactoros >= 1.0.0, < 1.8.4
    Fixed in
    1.8.4· Vendor fix available
    Issue
    zend-diactoros (and, by extension, Expressive), zend-http (and, by extension, Zend Framework MVC projects), and zend-feed (specifically, its PubSubHubbub sub-component) each contain a potential URL rewrite exploit. In each case, marshaling a request URI includes logic that introspects HTTP request headers that are specific to a given server-side URL rewrite mechanism. When these headers are present on systems not running the specific URL rewriting mechanism, the logic would still trigger, allowing a malicious client or proxy to emulate the headers to request arbitrary content.

    Recommended action: Upgrade to 1.8.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 6.1PackagistPublished

    zend-diactoros Cross-site Scripting (XSS)

    CVE-2015-3257 · GHSA-rh3c-7wqx-6w95

    Affected
    • Packagist zendframework/zend-diactoros >= 1.0.0, < 1.0.4
    Fixed in
    1.0.4· Vendor fix available
    Issue
    Zend/Diactoros/Uri::filterPath in zend-diactoros before 1.0.4 does not properly sanitize path input, which allows remote attackers to perform cross-site scripting (XSS) or open redirect attacks.

    Recommended action: Upgrade to 1.0.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. UnratedPackagistPublished

    URL Rewrite vulnerability in multiple zendframework components

    GHSA-f6p5-76fp-m248

    Affected
    • Packagist zendframework/zend-diactoros < 1.8.4
    Fixed in
    1.8.4· Vendor fix available
    Issue
    zend-diactoros (and, by extension, Expressive), zend-http (and, by extension, Zend Framework MVC projects), and zend-feed (specifically, its PubSubHubbub sub-component) each contain a potential URL rewrite exploit. In each case, marshaling a request URI includes logic that introspects HTTP request headers that are specific to a given server-side URL rewrite mechanism. When these headers are present on systems not running the specific URL rewriting mechanism, the logic would still trigger, allowing a malicious client or proxy to emulate the headers to request arbitrary content.

    Recommended action: Upgrade to 1.8.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →