URL Rewrite vulnerability in multiple zendframework components
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (zendframework/zend-feed 2.10.3; zendframework/zend-http 2.8.1; zendframework/zend-diactoros 1.8.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist zendframework/zend-feed
- Affected
- < 2.10.3
- Fixed in
- 2.10.3
Packagist zendframework/zend-http
- Affected
- < 2.8.1
- Fixed in
- 2.8.1
Packagist zendframework/zend-diactoros
- Affected
- < 1.8.4
- Fixed in
- 1.8.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f6p5-76fp-m248 lists affected ranges: Packagist zendframework/zend-diactoros >=0 =0 =0 <2.8.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
zend-diactoros (and, by extension, Expressive), zend-http (and, by extension, Zend Framework MVC projects), and zend-feed (specifically, its PubSubHubbub sub-component) each contain a potential URL rewrite exploit. In each case, marshaling a request URI includes logic that introspects HTTP request headers that are specific to a given server-side URL rewrite mechanism. When these headers are present on systems not running the specific URL rewriting mechanism, the logic would still trigger, allowing a malicious client or proxy to emulate the headers to request arbitrary content.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-f6p5-76fp-m248
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-f6p5-76fp-m248 Advisory: URL Rewrite vulnerability in multiple zendframework components IDs: GHSA-f6p5-76fp-m248 Record: https://patchnext.com/advisories/ghsa-f6p5-76fp-m248 (revision 1, source checked 26 Oct 2026, 13:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: zendframework/zend-feed 2.10.3; zendframework/zend-http 2.8.1; zendframework/zend-diactoros 1.8.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist zendframework/zend-feed: affected < 2.10.3; fixed in 2.10.3 - Packagist zendframework/zend-http: affected < 2.8.1; fixed in 2.8.1 - Packagist zendframework/zend-diactoros: affected < 1.8.4; fixed in 1.8.4 ## Suggested inspection (read-only) - Packagist zendframework/zend-feed: check the installed version with your package manager. - Packagist zendframework/zend-http: check the installed version with your package manager. - Packagist zendframework/zend-diactoros: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on zendframework/zend-feed, zendframework/zend-http, zendframework/zend-diactoros. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-f6p5-76fp-m248 (GitHub-reviewed advisory GHSA-f6p5-76fp-m248 lists affected ranges: Packagist zendframework/zend-diactoros >=0 =0 =0 <2.8.1) Commands are suggestions: review each one before running it.
Loading voting…