Skip to content

← Public intelligence

Packagist package

yiisoft/yii2-dev

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

6 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8PackagistPublished

    Yii SQL injection vulnerability

    CVE-2018-7269 · GHSA-hhg2-g6h6-c266

    Affected
    • Packagist yiisoft/yii2-dev < 2.0.12.1; >= 2.0.13, < 2.0.13.2; >= 2.0.14, < 2.0.15
    Fixed in
    2.0.152.0.13.22.0.12.1· Vendor fix available
    Issue
    The findByCondition function in framework/db/ActiveRecord.php in Yii 2.x before 2.0.15 allows remote attackers to conduct SQL injection attacks via a findOne() or findAll() call, unless a developer recognizes an undocumented need to sanitize array input.

    Recommended action: Upgrade to 2.0.15, 2.0.13.2 or 2.0.12.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 8.1PackagistPublished

    Yii Framework Code Injection

    CVE-2018-8074 · GHSA-m2p5-fwp2-qcw2

    Affected
    • Packagist yiisoft/yii2-dev >= 2.0.0, < 2.0.15
    Fixed in
    2.0.15· Vendor fix available
    Issue
    Yii 2.x before 2.0.15 allows remote attackers to inject unintended search conditions via a variant of the CVE-2018-7269 attack in conjunction with the Elasticsearch extension.

    Recommended action: Upgrade to 2.0.15 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 6.1PackagistPublished

    Yii Cross-site Scripting Framework vulnerability

    CVE-2017-11516 · GHSA-4c64-w8fg-xcq2

    Affected
    • Packagist yiisoft/yii2-dev >= 2.0.12, <= 2.0.12
    Fixed in
    2.0.13· Vendor fix available
    Issue
    An XSS vulnerability exists in framework/views/errorHandler/exception.php in Yii Framework 2.0.12 affecting the exception screen when debug mode is enabled, because $exception-errorInfo is mishandled.

    Recommended action: Upgrade to 2.0.13 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. High, CVSS 8.8PackagistPublished

    Yii Framework Cross-Site Request Forgery (CSRF)

    CVE-2018-6009 · GHSA-cwhm-272p-3wj9

    Affected
    • Packagist yiisoft/yii2-dev >= 2.0, < 2.0.14
    Fixed in
    2.0.14· Vendor fix available
    Issue
    In Yii Framework 2.x before 2.0.14, the switchIdentity function in web/User.php did not regenerate the CSRF token upon a change of identity.

    Recommended action: Upgrade to 2.0.14 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. High, CVSS 7.5PackagistPublished

    Use of Insufficiently Random Values in yiisoft/yii2-dev

    CVE-2021-3689 · GHSA-hq3v-rg6f-6hx4

    Affected
    • Packagist yiisoft/yii2-dev < 2.0.43
    Fixed in
    2.0.43· Vendor fix available
    Issue
    yii2 is vulnerable to Use of Predictable Algorithm in Random Number Generator

    Recommended action: Upgrade to 2.0.43 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. Medium, CVSS 5.3PackagistPublished

    Use of Cryptographically Weak Pseudo-Random Number Generator in yiisoft/yii2-dev

    CVE-2021-3692 · GHSA-wwvv-x5mq-h3jj

    Affected
    • Packagist yiisoft/yii2-dev < 2.0.43
    Fixed in
    2.0.43· Vendor fix available
    Issue
    yii2 is vulnerable to Use of Predictable Algorithm in Random Number Generator

    Recommended action: Upgrade to 2.0.43 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →