Skip to content

← Actionable
Critical, CVSS 9.8

Yii SQL injection vulnerability

CVE-2018-7269GHSA-hhg2-g6h6-c266

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (yiisoft/yii2-dev 2.0.15, 2.0.13.2, 2.0.12.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist yiisoft/yii2-dev

    Affected
    < 2.0.12.1>= 2.0.13, < 2.0.13.2>= 2.0.14, < 2.0.15
    Fixed in
    2.0.15, 2.0.13.2, 2.0.12.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2018-7269: 1.90% estimated exploitation activity in the next 30 days; percentile 79.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The findByCondition function in framework/db/ActiveRecord.php in Yii 2.x before 2.0.15 allows remote attackers to conduct SQL injection attacks via a findOne() or findAll() call, unless a developer recognizes an undocumented need to sanitize array input.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hhg2-g6h6-c266

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-7269

Advisory: Yii SQL injection vulnerability
IDs: CVE-2018-7269, GHSA-hhg2-g6h6-c266
Record: https://patchnext.com/advisories/cve-2018-7269 (revision 1, source checked 26 Oct 2026, 14:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: yiisoft/yii2-dev 2.0.15, 2.0.13.2, 2.0.12.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist yiisoft/yii2-dev: affected < 2.0.12.1; >= 2.0.13, < 2.0.13.2; >= 2.0.14, < 2.0.15; fixed in 2.0.15, 2.0.13.2, 2.0.12.1

## Suggested inspection (read-only)
- Packagist yiisoft/yii2-dev: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on yiisoft/yii2-dev.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hhg2-g6h6-c266 (GitHub-reviewed advisory GHSA-hhg2-g6h6-c266 lists affected ranges: Packagist yiisoft/yii2-dev >=0 =2.0.13 =2.0.14 <2.0.15)

Commands are suggestions: review each one before running it.

Loading voting…