Skip to content

← Public intelligence

Packagist package

yiisoft/yii

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1PackagistPublished

    Yii does not prevent XSS in scenarios where fallback error renderer is used

    CVE-2025-32027 · GHSA-7r2v-8wxr-3ch5

    Affected
    • Packagist yiisoft/yii < 1.1.31
    Fixed in
    1.1.31· Vendor fix available
    Issue
    Impact Affected versions of yiisoft/yii are vulnerable to Reflected XSS in specific scenarios where the fallback error renderer is used. Patches Upgrade yiisoft/yii to version 1.1.31 or higher. References - Git commit If you have any questions or comments about this advisory, contact us through security form.

    Recommended action: Upgrade to 1.1.31 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 8.1PackagistPublished

    yiisoft/yii deserializing untrusted user input can lead to remote code execution

    CVE-2023-47130 · GHSA-mw2w-2hj2-fg8q

    Affected
    • Packagist yiisoft/yii < 1.1.29
    Fixed in
    1.1.29· Vendor fix available
    Issue
    Impact Affected versions of yiisoft/yii are vulnerable to Remote Code Execution (RCE) if the application calls unserialize() on arbitrary user input. Patches Upgrade yiisoft/yii to version 1.1.29 or higher. For more information See the following links for more details: - Git commit - https://owasp.org/www-community/vulnerabilities/PHPObjectInjection If you have any questions or comments about this advisory, contact us through security form.

    Recommended action: Upgrade to 1.1.29 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 8.1PackagistPublished

    Prevent RCE when deserializing untrusted user input

    CVE-2022-41922 · GHSA-442f-wcwq-fpcf

    Affected
    • Packagist yiisoft/yii < 1.1.27
    Fixed in
    1.1.27· Vendor fix available
    Issue
    Impact Affected versions of yiisoft/yii are vulnerable to Remote Code Execution (RCE) if the application calls unserialize() on arbitrary user input. Patches Upgrade yiisoft/yii to version 1.1.27 or higher. For more information See the following links for more details: - Git commit - https://owasp.org/www-community/vulnerabilities/PHPObjectInjection If you have any questions or comments about this advisory, contact us through security form.

    Recommended action: Upgrade to 1.1.27 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. UnratedPackagistPublished

    Yii PHP Framework arbitrary PHP scripts execution

    CVE-2014-4672 · GHSA-74qv-rv53-5wcx

    Affected
    • Packagist yiisoft/yii >= 1.1.14, < 1.1.15
    Fixed in
    1.1.15· Vendor fix available
    Issue
    The CDetailView widget in Yii PHP Framework 1.1.14 allows remote attackers to execute arbitrary PHP scripts via vectors related to the value property.

    Recommended action: Upgrade to 1.1.15 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →