Prevent RCE when deserializing untrusted user input
CVE-2022-41922GHSA-442f-wcwq-fpcf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (yiisoft/yii 1.1.27), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist yiisoft/yii
- Affected
- < 1.1.27
- Fixed in
- 1.1.27
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-442f-wcwq-fpcf lists affected ranges: Packagist yiisoft/yii >=0 <1.1.27
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-41922: 1.25% estimated exploitation activity in the next 30 days; percentile 69.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Affected versions of yiisoft/yii are vulnerable to Remote Code Execution (RCE) if the application calls unserialize() on arbitrary user input. Patches Upgrade yiisoft/yii to version 1.1.27 or higher. For more information See the following links for more details: - Git commit - https://owasp.org/www-community/vulnerabilities/PHPObjectInjection If you have any questions or comments about this advisory, contact us through security form.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-442f-wcwq-fpcf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-41922 Advisory: Prevent RCE when deserializing untrusted user input IDs: CVE-2022-41922, GHSA-442f-wcwq-fpcf Record: https://patchnext.com/advisories/cve-2022-41922 (revision 1, source checked 26 Oct 2026, 14:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: yiisoft/yii 1.1.27. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist yiisoft/yii: affected < 1.1.27; fixed in 1.1.27 ## Suggested inspection (read-only) - Packagist yiisoft/yii: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on yiisoft/yii. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-442f-wcwq-fpcf (GitHub-reviewed advisory GHSA-442f-wcwq-fpcf lists affected ranges: Packagist yiisoft/yii >=0 <1.1.27) Commands are suggestions: review each one before running it.
Loading voting…