Skip to content

← Public intelligence

Packagist package

wp-premium/gravityforms

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.4PackagistPublished

    Gravity Forms stored HTML injection vulnerability

    CVE-2020-27851 · GHSA-fcj2-rxqc-294c

    Affected
    • Packagist wp-premium/gravityforms < 2.4.21
    Fixed in
    2.4.21· Vendor fix available
    Issue
    Multiple stored HTML injection vulnerabilities in the "poll" and "quiz" features in an additional paid add-on of Rocketgenius Gravity Forms before 2.4.21 allows remote attackers to inject arbitrary HTML code via poll or quiz answers. This code is interpreted by users in a privileged role (Administrator, Editor, etc.).

    Recommended action: Upgrade to 2.4.21 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 4.8PackagistPublished

    Gravity Forms stored Cross-Site Scripting (XSS) vulnerability

    CVE-2020-27850 · GHSA-wmh7-782f-xfw5

    Affected
    • Packagist wp-premium/gravityforms >= 2.4, < 2.4.21
    Fixed in
    2.4.21· Vendor fix available
    Issue
    A stored Cross-Site Scripting (XSS) vulnerability in forms import feature in Rocketgenius Gravity Forms before 2.4.21 allows remote attackers to inject arbitrary web script or HTML via the import of a GF form. This code is interpreted by users in a privileged role (Administrator, Editor, etc.).

    Recommended action: Upgrade to 2.4.21 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 5.4PackagistPublished

    Gravity Forms stored Cross-Site Scripting (XSS) vulnerability in the survey feature

    CVE-2020-27852 · GHSA-pjv5-v9gv-3679

    Affected
    • Packagist wp-premium/gravityforms >= 2.4, < 2.4.21
    Fixed in
    2.4.21· Vendor fix available
    Issue
    A stored Cross-Site Scripting (XSS) vulnerability in the survey feature in Rocketgenius Gravity Forms before 2.4.21 allows remote attackers to inject arbitrary web script or HTML via a textarea field. This code is interpreted by users in a privileged role (Administrator, Editor, etc.).

    Recommended action: Upgrade to 2.4.21 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. High, CVSS 7.5PackagistPublished

    Gravity Forms plugin leak hashed passwords

    CVE-2020-13764 · GHSA-m983-q76g-cwpq

    Affected
    • Packagist wp-premium/gravityforms < 2.4.9
    Fixed in
    2.4.9· Vendor fix available
    Issue
    common.php in the Gravity Forms plugin before 2.4.9 for WordPress can leak hashed passwords because userpass is not considered a special case for a $currentuser-get($property) call.

    Recommended action: Upgrade to 2.4.9 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →