Gravity Forms plugin leak hashed passwords
CVE-2020-13764GHSA-m983-q76g-cwpq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (wp-premium/gravityforms 2.4.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist wp-premium/gravityforms
- Affected
- < 2.4.9
- Fixed in
- 2.4.9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m983-q76g-cwpq lists affected ranges: Packagist wp-premium/gravityforms >=0 <2.4.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2020-13764: 1.83% estimated exploitation activity in the next 30 days; percentile 78.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
common.php in the Gravity Forms plugin before 2.4.9 for WordPress can leak hashed passwords because userpass is not considered a special case for a $currentuser-get($property) call.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-m983-q76g-cwpq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-13764 Advisory: Gravity Forms plugin leak hashed passwords IDs: CVE-2020-13764, GHSA-m983-q76g-cwpq Record: https://patchnext.com/advisories/cve-2020-13764 (revision 1, source checked 26 Oct 2026, 14:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: wp-premium/gravityforms 2.4.9. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist wp-premium/gravityforms: affected < 2.4.9; fixed in 2.4.9 ## Suggested inspection (read-only) - Packagist wp-premium/gravityforms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on wp-premium/gravityforms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m983-q76g-cwpq (GitHub-reviewed advisory GHSA-m983-q76g-cwpq lists affected ranges: Packagist wp-premium/gravityforms >=0 <2.4.9) Commands are suggestions: review each one before running it.
Loading voting…